Quicklizard - Settings selection incident – Incident details

All systems operational

Settings selection incident

Resolved
Degraded performance
Started 13 days agoLasted about 3 hours

Affected

UI

Degraded performance from 6:00 AM to 8:48 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved

  • Investigating
    Investigating

    We have noticed an issue with the settings page, and selecting competitors for price comparison competitors.