Quicklizard - Major Outage - April 12th 2025 – Incident details

All systems operational

Major Outage - April 12th 2025

Resolved
Major outage
Started about 2 months agoLasted about 14 hours

Affected

UI

Major outage from 2:00 AM to 3:44 PM

Pricing

Major outage from 2:00 AM to 3:44 PM

API

Major outage from 2:00 AM to 3:44 PM

Delivery Mechanism

Major outage from 2:00 AM to 3:44 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. We are int process of processing all the data

  • Identified
    Identified

    Our teams have identified the root cause and are working on implementing a solution

  • Investigating
    Investigating

    We are currently having an issue with the server, causing all our servers not to work and malfunction.