Scheduled maintenance Sunday, April 27th 2025
Scheduled for April 27, 2025 at 8:00 AM – 2:00 PM
Affects
UI
Under maintenance from 8:00 AM to 2:00 PM
Completed
April 27, 2025 at 2:00 PMCompleted
April 27, 2025 at 2:00 PMMaintenance has completed successfully
In progress
April 27, 2025 at 8:00 AMIn progress
April 27, 2025 at 8:00 AMMaintenance is now in progress
Planned
April 27, 2025 at 8:00 AMPlanned
April 27, 2025 at 8:00 AMWe are planning scheduled maintenance on Sunday, April 27th, 2025.
During this time, all updates and the user interface will remain fully functional, ensuring a seamless experience for users.
The only feature that will be temporarily unavailable is the Download to Excel button which will not work during the maintenance